На главную страницу
EnEn

Главная / Возможности / Разработчикам / Интеграция программы автоинформатора с 1C


Интеграция программы автоинформатора с 1C

На основе программы можно создавать различные сервисы по оповещению из базы 1С.

Одной из главных проблем современных, крупных и не очень, предприятий и компаний является то, что вся рабочая информация о ценах, клиентах, балансе, складе, сосредоточена чаще всего в одной базе данных. Зачастую у каждого предприятия эта база имеет свой формат и настроена по-своему, под нужды сотрудников и для их удобства. Это действительно очень удобно, но ровно до тех пор, пока не возникает необходимость использовать информацию из базы в каком-то стороннем приложении, или интегрировать её с каким-либо ПО. На этом этапе могут возникнуть самые различные проблемы – от трудностей в перенастройке до полной несовместимости форматов.

Вместе с тем, в любой развивающейся компании, подобный процесс внедрения инноваций и автоматизации работы неизбежен. Именно поэтому все больше руководителей отдают предпочтение решениям, которые заведомо совместимы с уже функционирующими в компании системами и базами данных.

Наиболее распространенный вариант организации документооборота и ведения клиентской (или любой другой) базы данных – это 1С. И, соответственно, в первую очередь, любое новое программное обеспечение должно без проблем интегрироваться именно с 1С.

Наш программный продукт Call Office – это телефонный автоинформатор, и абсолютно все его возможности могут быть использованы из 1С. А это значит, что вы сможете совершать автоматический обзвон указанной группы клиентов или рассылать sms-сообщения с произвольной информацией своему контакт-листу.

Это происходит довольно просто, так как возможности программ пакета 1С позволяют использовать внешние COM-объекты и вызывать их функции напрямую, не переключаясь из программы. Соответственно, и Call Office, являясь полноценным COM-объектом, может интегрироваться с 1С для создания сервисов по оповещению ваших клиентов напрямую из привычного интерфейса.

Самое главное, для того, чтобы взаимодействие 1С и Call Office стало возможным, не требуется огромных трудозатрат. Для того, чтобы вы убедились в этом на наглядных примерах, ниже мы приведем пример использования каждой из функций нашей программы на предприятии, и то, как она будет вызываться из 1С.

К примеру, если вы хотите, чтобы ваша система обзванивала список контактов, занесенных в базу данных 1С, и произносила абонентам сообщение с какой-либо информацией из той же базы данных, необходимо всего лишь встроить в вашу программу несколько строчек кода для подключения к Call Office

Пример:


Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.Dial ("8987654321 - номер вашего телефона", 40);
Если Result = 0 Тогда
   Device.Say ("Нужно заплатить за интернет.wav");
КонецЕсли;
Device.HangUp ();
Device.Close ();

Так же, программа может работать, как автоответчик. Это особенно удобно для предприятий, связанных с коммунальным обслуживанием. Если в вашей базе данных есть список телефонов абонентов, и сумма к оплате для каждого из них, то настроив автоответчик в программе и подключив её к вашей базе данных, вы сможете проигрывать каждому позвонившему абоненту голосовое сообщение с суммой его задолженности.

Пример:


Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.WaitForCall (-1);
Если Result = 0 Тогда
   Device.Say ("Ваша задолженость составляет");
КонецЕсли;
Device.HangUp ();
Device.Close ();

Еще одной полезной функцией программы является sms-рассылка. Информационные сервисы с рассылкой sms сообщений становятся все более популярны – их используют и как оповещение о новых услугах, и как напоминание об оплате, и как информирование о состоянии счета, и во многих других целях. Например, если вы хотите известить своих клиентов о том, что оплаченный период предоставления услуг заканчивается, в систему нужно встроить подобный код.

Пример:


Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.SendSMS ("8987654321 - номер вашего телефона", "Баланс вашего лицевого счета близок к нулю");
Если Result = 0 Тогда
   // Сообщение отправлено!
КонецЕсли;
Device.Close ();

Функция sms-автоответчика может быть полезна тем, кто периодически собирает информацию от клиентов. Полученное таким образом sms сообщение сохраняется в вашей базе данных, в нужном вам месте, и отпадает необходимость куда-то в ручную заносить полученную информацию. Например, можно по sms принимать заказы от клиентов, отправляя им в ответ автоматическое сообщение о том, что их заказ принят. Они будут сразу же заносится в вашу базу с номером телефона, с которого было отправлено сообщение и текстом sms, так что вы в дальнейшем сможете связаться с отправителем для уточнения деталей заказа.

Пример:


Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.WaitForSMS (-1);
Если Result = 0 Тогда
   // какое-либо действие на компьютере
КонецЕсли;
Device.Close ();

Как видите, программа Call Office может выполнять довольно разнообразные действия по информированию ваших клиентов, подстраиваясь под специфику деятельности любой компании, и при этом работая напрямую из 1С. Интеграция программ происходит довольно просто, а результат на выходе получается довольно впечатляющий. Узнайте больше о функциях программы Call Office и возможности её приобретения здесь.